Stencila Status

Errors creating project Snapshots

Resolved
Workers
Partial Outage

Creating a project Snapshot fails when attempting to pin the Docker container version.

2021-04-20T21:32:36.549Z
Resolved

The error stemmed from rotating all API tokens after the recent CodeCov security incident. After the tokens were regenerated, some of secrets were not updated in the deployed pods.

This caused the Worker process to attempt to use the outdated Docker credentials when pinning the project Snapshot, and hence fail.